Mazda CX-3 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Have this car less than a month. The alarm went off while driving and it has happened twice so far. The 4 way flash on and horn beeps I have to stop the car turn off engine to reset it. Any idea?
 

·
Registered
Joined
·
745 Posts
Have this car less than a month. The alarm went off while driving and it has happened twice so far. The 4 way flash on and horn beeps I have to stop the car turn off engine to reset it. Any idea?
What does your Owner's Manual say? Do you have an Intrusion Alarm? Mine says something about the 4-way flashers and horn.

Intrusion Alarm? Are you sure you're the owner ;-)

Seriously, where are you located, and what Year and Model is your CX-3?
 

·
Registered
Joined
·
745 Posts
Dunno ... O'Canada and 2019 ... again, is there anything in your Owner's Manual?

Otherwise, it's a trip across Lions Gate Bridge to the dealer.

Good Luck ... and, Oh ... Welcome to our happy group :)
 

·
Registered
Joined
·
2 Posts
Have this car less than a month. The alarm went off while driving and it has happened twice so far. The 4 way flash on and horn beeps I have to stop the car turn off engine to reset it. Any idea?
I got the same problem. My alarm went off while driving 5 times already in 2 weeks, and it happened twice while it rained. Quite annoying when you have to move 3 lanes to the shoulder with 4 way flash and horn blaring to restart the engine which is the ONLY way to fix this issue..
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I took this car to the dealer two weeks ago. They couldn't find any problem so they did the ECM reset and reprogrammed both keys. Apparently they didn't fix it, same problem has happened 3 times in the past 4 days. I will book an appointment with different dealer tomorrow.
 

·
Registered
Joined
·
2 Posts
I took this car to the dealer two weeks ago. They couldn't find any problem so they did the ECM reset and reprogrammed both keys. Apparently they didn't fix it, same problem has happened 3 times in the past 4 days. I will book an appointment with different dealer tomorrow.
Do you still have the problem after your last visit?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
I went to Mazda dealer again and left my car there for five days. They did reproduce the problem unfortunely they do not have a solution. After I contact Mazda Canada, they installed a data recorder into my car in order to find out what trigger the alarm system. This recorder will stay in the car for one month and then will be sent to Japan for analysing. So I will drive this defective cx 3 for a while. I will update.
 

·
Registered
Joined
·
6 Posts

·
Registered
Joined
·
486 Posts
I posted the solution here: https://www.cx3forum.com/forum/engines-technical-discussion/18365-2019-cx-3-panic-lemon.html
You need to have the dealer replace a TPMS sensor that's transmitting at the same frequency as the alarm. Sounds crazy. Took me two visits but there should be a bulletin issued by Mazda about it that the dealer can reference. If they can't figure it out, tell them to call Wellesley Mazda in Wellesley, Mass. They figured it out... :)
Holy-.. That is probably one of the most random things to overlook when building the car. Makes me wonder if its a model year issue or just certain "batch" number.

Also did they switch to tpms on the valve stem for 2019 or is it still rotational measured tpms(doesnt need sensor in the valve stem like traditional cars)?
 

·
Registered
Joined
·
6 Posts
Holy-.. That is probably one of the most random things to overlook when building the car. Makes me wonder if its a model year issue or just certain "batch" number.

Also did they switch to tpms on the valve stem for 2019 or is it still rotational measured tpms(doesnt need sensor in the valve stem like traditional cars)?
I don't know if it's one or the other. I'll try to dig up the invoice/statement from the dealer to see if it gets specific enough to answer your question.
 

·
Registered
Joined
·
6 Posts
Holy-.. That is probably one of the most random things to overlook when building the car. Makes me wonder if its a model year issue or just certain "batch" number.

Also did they switch to tpms on the valve stem for 2019 or is it still rotational measured tpms(doesnt need sensor in the valve stem like traditional cars)?
Valve stem. Here is the detail of the parts from the invoice:

1 BHA4-37-140A Sensor, Wheel
1 GS1D-37-141A Nut, Valve

Notes they included:
"Contacted Mazda hotline, faulty left front TPMS sensor, replaced sensor, verified repair."

Was it previously not on the valve stem? Hmmmm.
 

·
Registered
Joined
·
95 Posts
Metrowestcx3, the 2019 CX-3 is the first year to have direct TPMS, so previous years did not have a sensor in the tire or on the valve stem.

The prior years used software and the ABS to detect low tire pressure, which may not be as accurate, but you didn't have to replace sensors when their batteries died or when going to a different tire/wheel combination.
 

·
Registered
Joined
·
486 Posts
Thank you to both of you for confirming, it brings an extra complexity to switching wheels since the earlier models just let you swap around. I have to update an earlier post from this new info.
 
1 - 14 of 14 Posts
Top