Mazda CX-3 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I usually settle down on the MPG etc. display on the monitor, after setting the radio. No problems, until today.
The monitor display seemed to working correctly (judging from my actual speed) but the separate small
MPG display (beneath the cruise control setting) on the dashboard suddenly started changing repeatedly, all
on its own. It changed every 2-3 seconds, gradually going from 7 to 13 to 23 to 28 to 42 to 76 to 88 to 99.9
and back again!
This is new, never happened before, and it just kept repeating over and over for the entire 20 minute trip.
I tried stopping and restarting again but with no change. I have no clue as to why or where to check to
adjust/reset. Seems probably computer related. Anyone else ever have it happen, or know what to do,
besides going back to the dealer :eek:
Oh, yeah used 2018 CX3 sport, roughly 16,000 miles.
Otherwise running just fine.
Thanks!
 

·
Registered
2020 2wd CX-3
Joined
·
14 Posts
I usually settle down on the MPG etc. display on the monitor, after setting the radio. No problems, until today.
The monitor display seemed to working correctly (judging from my actual speed) but the separate small
MPG display (beneath the cruise control setting) on the dashboard suddenly started changing repeatedly, all
on its own. It changed every 2-3 seconds, gradually going from 7 to 13 to 23 to 28 to 42 to 76 to 88 to 99.9
and back again!
This is new, never happened before, and it just kept repeating over and over for the entire 20 minute trip.
I tried stopping and restarting again but with no change. I have no clue as to why or where to check to
adjust/reset. Seems probably computer related. Anyone else ever have it happen, or know what to do,
besides going back to the dealer :eek:
Oh, yeah used 2018 CX3 sport, roughly 16,000 miles.
Otherwise running just fine.
Thanks!
Not being presumptuous here, but you don't have the mileage reading on actual fuel consumption, rather than average consumption, do you?

When I was playing around with the menu on mine when I first got it, the actual consumption readout jumped about all over the place as I accelerated or braked. I then set it on average which gives a steady consistent reading.

Just a thought.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Thanks for responding! Unsure what you mean by "presumptuous"...anyway, I have made no "intentional" changes to anything. I don't know how!
The problem was occurring while driving at a steady 65mph, (cruise control on), on the highway, for about 20 minutes. No braking, slowing, starting and stopping.
Numbers ranged as noted above, cycling every 2-3 seconds and then continued, as noted, when I left the highway. Where do I find the menu you mentioned, so I might check how it's set?
 

·
Registered
Joined
·
653 Posts
Thanks for responding! Unsure what you mean by "presumptuous"...anyway, I have made no "intentional" changes to anything. I don't know how!
The problem was occurring while driving at a steady 65mph, (cruise control on), on the highway, for about 20 minutes. No braking, slowing, starting and stopping.
Numbers ranged as noted above, cycling every 2-3 seconds and then continued, as noted, when I left the highway. Where do I find the menu you mentioned, so I might check how it's set?
You might have pressed the up or down arrow on the right sideof the steering wheel buttons and switched from average to instantaneous mpg consumption which reads current rating into how much mpg it would be using if you were to continue exact same throttle/speed/gear l consumption. Its exactly the number range you described. Low gear acceleration is terribly low then jumps to high and even some unrealistic high numbers when youre off the gas and on a downhill decline road. Switch through the display with up down to go back to average if thats what youre used to. But keep in mind average is kind of useless if not reset after ever gas fillup since itl use older values into a big calculation until next reset and dilutes overall rating
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
SlyCoopers, thanks! You were absolutely right and things are back to normal again! Inadvertently discovered that switch would change radio stations, without fiddling with
monitor, so I used it a couple of times and apparently pressed the up/down arrows and the info switch. Frankly, I never used that switch because I thought it only had to do with
the telephone stuff, which I don't use anyway. :)
 
1 - 5 of 5 Posts
Top