Mazda CX-3 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I seem to have cocked up !, have had the centre console out of the CX3 to fit the Mazda armrest. disconnected the middle console (with the audio/sat nav/settings etc rotating wheel control) job finished, arm rest good but after the full re-assembly the display tells me that my car does not have the facility or ability to provide navigation, even though it was working prior to the disconnect and I still have a valid card in the panel, I removed and replaced the card but still no sat-nav, obviously I have upset it some way, so do I now have to take it back to my dealer and get reprogrammed or what, any help appreciated, rgds, Paul H.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #2
Should have added, all other functions, Audio etc working perfectly just the sat-nav gone awol ?.
 

·
Registered
Joined
·
118 Posts
Try resetting the CMU (press Mute, Back and Nav buttons around the command wheel all at the same time for 20 seconds).
If that doesn't work, it sounds like you've got a bad/missing connection at the back of the SD card reader. If the card appears to be missing you'll get the message that says navigation is not installed and it'll display a compass instead of the map.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4
Hi thank you for the reply, going to go through the process again later and make sure all connections secure, but puzzle, in the area under the centre console behind the gear lever is a multi pin male plug that isn't connected to anything, any ideas on its purpose, unable to find anything on the wiring diagram ?. again appreciate your reply, rgds, Paul H.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
Sorted, thanks for info, took the console out and wiggled the plug at back of card unit, all sorted, now have sat nav back as before, thanks for replies, rgds, Paul H.
 
1 - 5 of 5 Posts
Top