Mazda CX-3 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Yesterday I noticed my moon roof won't not open, so I check the fuse and sure enough, it was blown.
I took one of the spare ones located in the engine compartment and used the fuse puller to take out the old one and when I pushed in the new one it sparked a little.
When I when back into the car. nothing worked. the push-button start just flashed green. I called the dealer and they said it was the key and walked me thru getting it started with the key.... which worked.
however, I'm not convinced it was the key. Now half the car's electronics are not working ( interior lights and Head unit is dead, none of the automatic features are working) and the engine light is on and this is the only way to get it started.
I am out of warranty and desperately try to get this back to normal.

Any ideas?
 

·
Registered
Joined
·
32 Posts
"I took one of the spare ones located in the engine compartment"
Are you sure there are spare fuses in the fuse box?
I am not sure about your car, but I have not seen spare fuses in the fuse box in mine.

"Now half the car's electronics are not working "
I think you pulled a fuse which was in use.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Yes, the fuse box in the engine compartment has spare ones on the underside of the top, along with the fuse puller.
 

·
Registered
Joined
·
32 Posts
I stand corrected.
I took a look at the inner side of the lid of the fuse box.
And there they are: spare fuses! I have never noted them before.
Never too old to learn something new.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
It's pretty handy! Going to the dealer Friday.... fingers crossed...hopefully, it's something small.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #7
Finally all better... but $387 from the dealer. They reset the engine faults and replace a cracked fuse that controlled most of the stuff that wasn't working.
 
1 - 7 of 7 Posts
Top