Mazda CX-3 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all

Recently bought a 2017 cx 3, pre registered.

Very happy with the car.

One wierd issue i have, the heads up display and the digital speedo never match...odd.

The heads up display always states 1mph more than the digital speedo in the instrument panel.

Any ideas?I

Sadly, the dealer is useless...

Thanks
 

·
Super Moderator
Joined
·
2,078 Posts
Yes, it is a feature of the HUD to behave like that. The speedo gets its inputs from the wheel speed sensors (all four of them) and the HUD gets its from the gps which just like any satnav unit runs slightly out of sync. You’ll find the cruise control syncs with the HUD which could leave you speeding in some cases. Nothing you can do as far as I know.
 

·
Registered
Joined
·
872 Posts
Are you sure the HUD gets its speed reading from GPS? That is news to me. My HUD is always spot on the digital display in the tach, i've never had a discrepancy between the readings.
 

·
Registered
Joined
·
142 Posts
Are you sure the HUD gets its speed reading from GPS? That is news to me. My HUD is always spot on the digital display in the tach, i've never had a discrepancy between the readings.
I'll second that. Numbers have always matched for me.
 
  • Like
Reactions: Cyclone1410

·
Super Moderator
Joined
·
2,078 Posts
Yes, they did match on my 16 but the ones on my CX-5 are way out and the HUD doesn’t work at all without the SD card fitted. I’m making the assumption that the op has the later version with the coloured display and it works like mine.
 

·
Registered
Joined
·
256 Posts
Yes, they did match on my 16 but the ones on my CX-5 are way out and the HUD doesn’t work at all without the SD card fitted. I’m making the assumption that the op has the later version with the coloured display and it works like mine.
That might explain it.
Don't You have a super cool pdf describing how the HUD works (hopefully both for the old and the new version)? :D
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Yes, it is a feature of the HUD to behave like that. The speedo gets its inputs from the wheel speed sensors (all four of them) and the HUD gets its from the gps which just like any satnav unit runs slightly out of sync. You’ll find the cruise control syncs with the HUD which could leave you speeding in some cases. Nothing you can do as far as I know.
Ahh interesting... The dealer told me this, but to be honest I didn't believe them. I can't believe the two are not in sync with each other...bizzare.

A friend has a mazda 3...the speedo and HUD match.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Yes, they did match on my 16 but the ones on my CX-5 are way out and the HUD doesn’t work at all without the SD card fitted. I’m making the assumption that the op has the later version with the coloured display and it works like mine.
Yes...maybe it's a UK 'thing's where they ar not in sync.
 

·
Super Moderator
Joined
·
2,078 Posts
That might explain it.
Don't You have a super cool pdf describing how the HUD works (hopefully both for the old and the new version)? :D
Hmmm, let me see.

The first is the “original” version. The one called “dash HUD” is the latest full colour version and this is the one I have. The speed in the HUD is always faster than the speedo. Finally I’ve added the one with the TSR and on the first page it states that the system won’t work without the SD card.
 

Attachments

·
Registered
Joined
·
256 Posts
Hmmm, let me see.

The first is the “original” version. The one called “dash HUD” is the latest full colour version and this is the one I have. The speed in the HUD is always faster than the speedo. Finally I’ve added the one with the TSR and on the first page it states that the system won’t work without the SD card.
Thanks :)
I've read the TSR won't work without the SD card (it's even mentioned in the Danish brochures) but speed and the other functions (such as MRCC, BSM, LDW) should still work, even without an the SD card.
 
1 - 11 of 11 Posts
Top