Mazda CX-3 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi,

I have a 2016 CX-3. I recently started seeing water pouring out from the hatch when I lift it up after it rains. All electronics, for now, are ok and there is no water in the rear lights. Any thoughts on where this leak might be coming from? The spoiler does seem to have a little more play in it than I'd expect, but it's not terrible so I am thinking that may be normal. Wondering if anyone else has seen this and if it's been narrowed down to one or two areas to check. Couldn't find too much searching here yet and there hasn't been any work done to the car in that area before

Thanks!
 

·
Registered
Joined
·
18 Posts
Check your passenger side light that is attached to the hatch. Mine was leaking thru there. Purchased a new gasket for light and hasn’t leaked since.
 

·
Registered
Joined
·
7 Posts
Check your passenger side light that is attached to the hatch. Mine was leaking thru there. Purchased a new gasket for light and hasn’t leaked since.
Reviving this old thread as I too have this issue. I can see condensation in the rear light on the hatch on the drivers side, so my assumption is the water is entering through there. Anyone have a link to the replacement parts for the gaskets? I performed a quick google search and come up with everything but the actual gasket for that light for my 16' cx-3. Much appreciation in advance for any help!
 

·
Registered
Joined
·
7 Posts
Reviving this old thread as I too have this issue. I can see condensation in the rear light on the hatch on the drivers side, so my assumption is the water is entering through there. Anyone have a link to the replacement parts for the gaskets? I performed a quick google search and come up with everything but the actual gasket for that light for my 16' cx-3. Much appreciation in advance for any help!
Also, should add, after some more digging on eBay, the right rear gasket is readily available, but not seeing the left/drivers side, so for what it's worth and just for the sake of extra clarity, that is the side I am on the lookout for.
 

·
Registered
Joined
·
49 Posts
Had the same problem. Removed both tail lights, applied clear silicone sealer and reinstalled them. Problem solved.
 
1 - 5 of 5 Posts
Top