Mazda CX-3 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All, I have a 2015 CX-3 diesel (Japanese Import) and I had it serviced in Jan (so 4 months ago) when the wrench light initially came on, at the time the warnings listed the car was due for a service. Car was serviced and the light was reset.
A month or so later, the light came back on (not flashing) and I took it to Mazda, because at this point using the reset option on the onboard infotainment did not reset the light, they plugged in something (assuming an OBD) and reset a couple of things and the light was gone. (PS I had to pay $50 to reset the light)
Now again 3/4 weeks later the light is back, but now it's flashing...? Mazda is a bit confused and everything they tried (including the tip meter and engine start button reset method is not working to reset the light, they've also disabled the setting to warn for the service.)
Has anyone had this issue before as there is no definition for a flashing wrench light? The mechanics are saying it's a glitch and they're not really offering any solution.. other than booking the car for a diagnostics to see what's wrong.

PS the car drives like a dream, when driving it does not feel like anything is wrong with the car.. also when serviced they replaced the oil and the engine filter.

I'm hoping that there's someone else out there that had this issue before and has a solution for me?? Thanks
 

·
Registered
Joined
·
1 Posts
Hi All, I have a 2015 CX-3 diesel (Japanese Import) and I had it serviced in Jan (so 4 months ago) when the wrench light initially came on, at the time the warnings listed the car was due for a service. Car was serviced and the light was reset.
A month or so later, the light came back on (not flashing) and I took it to Mazda, because at this point using the reset option on the onboard infotainment did not reset the light, they plugged in something (assuming an OBD) and reset a couple of things and the light was gone. (PS I had to pay $50 to reset the light)
Now again 3/4 weeks later the light is back, but now it's flashing...? Mazda is a bit confused and everything they tried (including the tip meter and engine start button reset method is not working to reset the light, they've also disabled the setting to warn for the service.)
Has anyone had this issue before as there is no definition for a flashing wrench light? The mechanics are saying it's a glitch and they're not really offering any solution.. other than booking the car for a diagnostics to see what's wrong.

PS the car drives like a dream, when driving it does not feel like anything is wrong with the car.. also when serviced they replaced the oil and the engine filter.

I'm hoping that there's someone else out there that had this issue before and has a solution for me?? Thanks

Hi there,

I have the exact same issue with my wifes cx3 diesel engine..

Please do share if you get to the bottom of it.

Kind regards

Thanks
Hi All, I have a 2015 CX-3 diesel (Japanese Import) and I had it serviced in Jan (so 4 months ago) when the wrench light initially came on, at the time the warnings listed the car was due for a service. Car was serviced and the light was reset.
A month or so later, the light came back on (not flashing) and I took it to Mazda, because at this point using the reset option on the onboard infotainment did not reset the light, they plugged in something (assuming an OBD) and reset a couple of things and the light was gone. (PS I had to pay $50 to reset the light)
Now again 3/4 weeks later the light is back, but now it's flashing...? Mazda is a bit confused and everything they tried (including the tip meter and engine start button reset method is not working to reset the light, they've also disabled the setting to warn for the service.)
Has anyone had this issue before as there is no definition for a flashing wrench light? The mechanics are saying it's a glitch and they're not really offering any solution.. other than booking the car for a diagnostics to see what's wrong.

PS the car drives like a dream, when driving it does not feel like anything is wrong with the car.. also when serviced they replaced the oil and the engine filter.

I'm hoping that there's someone else out there that had this issue before and has a solution for me?? Thanks

Hi there,

I do have the same problem with my wifes cx3 diesel.

Flashing wrench light appeared on the drive back from work.

Have tried resetting but hasn't worked.

Do share if you get to the bottom of it.

Thank you

Kind Regards
 
1 - 5 of 5 Posts
Top