Mazda CX-3 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Ok, 2017 CX-3, one brake light is out but turn signal works (same single filament amber bulb).

Bought new bulb, brake light still not working.

Switch bulb from other side that works, still no brake light.

Cleaned inside of socket with electric circuit cleaner, metal contacts inside socket intact and in-place.

This has me stumped, before I have to bring it to a Mazda dealer, anyone have any input.

Thanks...
 

·
Registered
Joined
·
550 Posts
I would figure its a wire connection issue. Alot of plugs in other cars Ive had issues with the wire terminals loosening (pulling back) from plugs along the connection. Had a similar issue in my familys nissan sentra. Would be worth looking for something similar to at least cross it off a list.

So for example to give you an idea of what Im talking about ,I uploaded a pic of h11 plugs. The 2 wires are basically held by an orange rubber gasket on the plug itself. They can very easily be pulled out even just a little enough to break the connection.
 

Attachments

·
Registered
Joined
·
20 Posts
Discussion Starter #3
No mystery after all....It seems that when the body shop (2 years ago+) replaced the back lower panel & bumper cover, they revered the sockets in the rear lights...My wife has been driving around for that long with clear brake lights.....The two filament bulb that handles the brake and tail lights had one broken contact (brake).....In two years +, I never drove behind her or I would have picked up on clear brake lights.....$9+ for two bulbs and the issue is resolved....
 
1 - 3 of 3 Posts
Top