Mazda CX-3 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hey all, quick question here. Is anyone else having problems with their Bluetooth not staying connected? I have a Nexus 6p that I've been using just fine since I got the car in April. Then a few weeks ago the Bluetooth wouldn't connect at all, I restarted the car and all was fine. Then yesterday it would only connect to the media profile and not the phone. I reset the heat unit (nav, back, and mute button combo) and it connected fine, for about a minute. It then disconnected, reconnected 20 seconds later, then disconnected for good 10 seconds after that. It's been the same story since. I've reset the head unit twice in that time with the same results (though it sometimes stays connected for a few minutes before it drops it). It actually cut out in the middle if a call tonight. Is there a simple fix for this or should I contact the dealer and see if they can look into it? I use the Bluetooth on the phone all the time with other devices without a problem, so I really doubt it is that. I've got the most recent firmware (both car and phone), and as far as I can tell nothing changed on either end from "working fine" to "no phone for you".
 

·
Registered
Joined
·
893 Posts
I would say the issue is most likely the phone. Perhaps a recent update is to blame. I've used multiple Android phones in my car with no issues, granted I haven't used a Nexus. Do you have another phone you can try?
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
I am pretty sure it is not my phone as the phone connects to three other Bluetooth devices almost daily with no issues what so ever. This problem continued all weekend until Monday evening when, like magic, everything worked as advertised once more, within 30 seconds of starting the car everything would connect like they were old friends and have continued this way ever since. As for other devices, I can try to hook my Nexus tablet up to the car but that may not have a "phone" profile to connect to since it is a tablet, though as a cellular Android device it may, I do not know and have not yet tried.
 

·
Registered
Joined
·
8 Posts
I have a similar issue but it shows my phone is connected to the car and works great for music.
I have a Samsung S7 edge and the phone will answer phone calls perfect in different calls, so its not the phone.
My Cx3 will show the call coming in and you can answer it with the car but it "Transfers to handset(phone)" and shows you on the call until you hang up.
Ive tried pressing "Transfer to car" while on the call and it will always go back to the handset(phone).
 
1 - 4 of 4 Posts
Top