Mazda CX-3 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Last Dec, I bought a pre-owned 2016 CX3. Now that it's warm, I noticed that the A/C doesn't work. Opening up the hood, the compressor does not turn when the A/C is turned on. I checked the fuses, they're good. The refrigerant is full (tried to add more and couldn't). There aren't any grinding or unusual sounds from the engine. Air still comes out the vents, just not cold.

Any ideas?

Thanks!
 

·
Registered
Joined
·
464 Posts
If you have any sort of warranty from a dealer I would suggest to have it addressed as soon as possible before it runs out. Its unfortunate that theres been a couple TSBs around for some 16-17 models having poorly welded evaporator or condenser (whatever the part was called cant remember exactly). Quite a few of us with 16s have had the same issue happen and it took almost 3 years for it to happen to me. Not sure if you are having a similar problem but this is one of the downsides of the early production years cx-3s. Usually the issue is refrigerant leaks out and ac just wont cool down. Yours not starting but still having full readings seems more unique and specific case however.

As a first step, is the light coming on when you set it to turn on the AC? If it doesnt there might be a broken connection in the relay to send power to the ac unit.
Also do you hear anything unusual when turning on the front defroster? The ac system should be initiated by default when using front defroster (this was how I diagnosed my ac issue in the first place in winter ironically), you wont see the light turn on in this mode however.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The light does come on when I turn on the A/C.

No unusual sounds from the defroster. However, the A/C does not automatically go on when the defroster is turned on.
 

·
Registered
Joined
·
221 Posts
Last Dec, I bought a pre-owned 2016 CX3. Now that it's warm, I noticed that the A/C doesn't work. Opening up the hood, the compressor does not turn when the A/C is turned on. I checked the fuses, they're good. The refrigerant is full (tried to add more and couldn't). There aren't any grinding or unusual sounds from the engine. Air still comes out the vents, just not cold.

Any ideas?

Thanks!
Is there no really cold air at all, even when the temperature is set to the minimum? If there is some at the minimum setting, but none otherwise, it could point to a faulty control unit panel - the three dials section - which was also a problem on early CX-3's along with the evaporator and condenser problems mentioned by SlyCoopers in his post. It should be covered by warranty if you still have some left, or possibly some kind of goodwill part payment. I think you need to take you car to your dealer for them to investigate and advise on a fix.
 

·
Registered
Joined
·
90 Posts
You can't add refrigerant without the compressor running. If you try, the pressure will read full or high, but no refrigerant will go in. It's likely that the system has leaked, and the compressor won't turn on due to low refrigerant. I would recommend, as Sly suggested, to take it to the dealer ASAP if it has any sort of warranty. Even if it's out of warranty, take it to the dealer and see if Mazda is willing to cover part or all of the repair costs.

TSB ID 07-004-17-3332a
TSB ID 07-001-18-3465
TSB ID 07-001-18-3274b
 

·
Super Moderator
Joined
·
2,078 Posts
The compressor doesn’t run full time, it cuts in and out as required. The fans always run when the compressor runs.
 

·
Registered
Joined
·
4 Posts
When the freon is low the compressor will not cycle, and will run continuously until the pressure is at the proper range. Also no cooling will not allow it to cycle on low temp.

He should try to supply the compressor with 12v directly and see if it turns then and trouble shoot backwards electrically from that point....
 

·
Registered
Joined
·
1 Posts
Hi.. I just joined the forum.. found out Saturday that my 2016 ac compressor was leaking.. 28k miles.. used it for 2 summers in NY.. just 3 months out of my warranty.. also found out there is a TSB regarding this sent out in January 2019.. I’m very disappointed with my first time Mazda purchase. Hoping this eventually turns into a recall so I can be reimbursed for all the money I had to spend on a new compressor!
 

·
Registered
Joined
·
464 Posts
Hi.. I just joined the forum.. found out Saturday that my 2016 ac compressor was leaking.. 28k miles.. used it for 2 summers in NY.. just 3 months out of my warranty.. also found out there is a TSB regarding this sent out in January 2019.. I’m very disappointed with my first time Mazda purchase. Hoping this eventually turns into a recall so I can be reimbursed for all the money I had to spend on a new compressor!
Sorry to hear that, I would try to get in contact with mazda USA operations customer service. Usually theyre pretty good about this stuff especially with a tsb since its a 'known' but not recalled issue so you have grounds for a case in your favor.
 

·
Registered
Joined
·
1 Posts
A/C blows hot and out of warranty :(

You can't add refrigerant without the compressor running. If you try, the pressure will read full or high, but no refrigerant will go in. It's likely that the system has leaked, and the compressor won't turn on due to low refrigerant. I would recommend, as Sly suggested, to take it to the dealer ASAP if it has any sort of warranty. Even if it's out of warranty, take it to the dealer and see if Mazda is willing to cover part or all of the repair costs.

TSB ID 07-004-17-3332a
TSB ID 07-001-18-3465
TSB ID 07-001-18-3274b
Has anyone had luck with getting this fixed at Mazda's expense out of warranty? I bought a 2016 CX-3 last week and the A/C doesn't blow cold air. I called Mazda and the car ran out of warranty in May, but only has 35,000 miles on it. The service department recommended that I have them diagnose it for $240 and they can send it in to Mazda and see if they will still cover the costs since it's so close to warranty. I'm just curious what my chances of getting it fixed are?

Brand new to the forum, my apologies if my formatting isn't up to par :)
 
1 - 11 of 11 Posts
Top