Mazda CX-3 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello,

I finally picked up my 2018 CX3 GT FWD a couple of days ago. Thank you for all your great help.
I have been looking for a GT FWD model in Titanium Flash/Parchment conbo since last year, so I am very excited to be the owner of it.
However... my Mazda Connect infotainment system is not working correctly. I can't press most of the buttons...so I have to take it back to the dealership. Bummer! Hopefully it is nothing serious.

Anyway, thank you gentlemen for your help!
 

·
Super Moderator
Joined
·
108 Posts
Hello,

I finally picked up my 2018 CX3 GT FWD a couple of days ago. Thank you for all your great help.
I have been looking for a GT FWD model in Titanium Flash/Parchment conbo since last year, so I am very excited to be the owner of it.
However... my Mazda Connect infotainment system is not working correctly. I can't press most of the buttons...so I have to take it back to the dealership. Bummer! Hopefully it is nothing serious.

Anyway, thank you gentlemen for your help!
Check and see if these buttons work while you are parked. A lot of the features disable when you are moving.
 

·
Registered
Joined
·
256 Posts
Hello,

I finally picked up my 2018 CX3 GT FWD a couple of days ago. Thank you for all your great help.
I have been looking for a GT FWD model in Titanium Flash/Parchment conbo since last year, so I am very excited to be the owner of it.
However... my Mazda Connect infotainment system is not working correctly. I can't press most of the buttons...so I have to take it back to the dealership. Bummer! Hopefully it is nothing serious.

Anyway, thank you gentlemen for your help!
Which buttons are we talking about?
If it's the settings for lights, locks and so on, You have to press the start button twice (if You're not depressing the brakepedal) or start the engine.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Most of the Main Menu buttons such as Nav, App, Music and etc... I can click on Settings button and sometimes App button. I have tried in every scenarios (pressing the start button once or twice or start the engine) and it does not work. I can't scroll up and down either, but sometimes it works. Screen freezes sometimes, too. Resetting to factory setting didn't work either...
 

·
Super Moderator
Joined
·
2,078 Posts
Off topic. What is going on with the 100 new topics writen with strange language in the forum for the past days?
DJ has made the admins aware and he and I are watching the sad creature.
 
1 - 17 of 17 Posts
Top