AC hasn't worked since New. Going to the shop today. - Mazda CX3 Forum
User Tag List

 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 Old 02-21-2017, 12:44 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Location: Holton Kansas
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
AC hasn't worked since New. Going to the shop today.

I bought my 2016 Touring new Dec 13th so I really havn't needed the AC but it has been in the mid 70's and got some time so it's getting looked at today. The AC clutch doesn't kick in and i've checked the fuse. I'll let everyone know what they find.
Charlie Ireland is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old 02-22-2017, 12:47 AM Thread Starter
Junior Member
 
Join Date: Jan 2017
Location: Holton Kansas
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
There wasn't any freon in the system. They charged it and it and there was a leak in something. I can't for the life of me remember what he said they ordered but the parts are to be in Friday. 76 tomorrow and backin the 40's Friday so no big deal as long as it gets fixed and isn't an ongoing issue. I'll keep you posted on what they actually fix.
Sarah likes this.
Charlie Ireland is offline  
post #3 of 20 Old 02-25-2017, 04:26 PM
Junior Member
 
Join Date: Jan 2017
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
My AC only works on full blast. I have an appointment this week to have it checked out. I hope they hook me up with a fully loaded loaner car!
Tyler McDermid is offline  
 
post #4 of 20 Old 02-28-2017, 10:39 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Location: Holton Kansas
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
I took the CX-3 back in today and they replaced the expansion valve. I guess it wasn't a leak but it is building to much pressure and shutting down. They told me the head mechanic with 30 years of experience stumped and are waiting on Mazda Tech support so it is spending the night at the shop. I'll keep you all posted
Charlie Ireland is offline  
post #5 of 20 Old 03-02-2017, 01:23 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Location: Holton Kansas
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Went and picked up the car and they have now ordered a condesor/dryer assembly to be installed Tuesday. And the saga does on.
Charlie Ireland is offline  
post #6 of 20 Old 03-02-2017, 04:28 PM
Super Moderator
 
anchorman's Avatar
 
Join Date: Jul 2015
Location: Derbyshire UK
Posts: 2,078
Mentioned: 41 Post(s)
Tagged: 0 Thread(s)
Quoted: 483 Post(s)
Garage
Quote:
Originally Posted by Charlie Ireland View Post
Went and picked up the car and they have now ordered a condesor/dryer assembly to be installed Tuesday. And the saga does on.
The condenser/evap is a known issue. They should have done it in the first place.
Attached Files
File Type: pdf Air Conditioner - No Cool Air (Evaporator Leakage).pdf (371.0 KB, 264 views)
TiGrayMSM and bjn like this.

Currently CX5 SportNav 2.2 diesel automatic and AWD.
Formerly CX3 SportNav 1.5 diesel automatic and AWD.

All advice is given in good spirit and taken entirely at the readers own risk. WORK SAFELY. ©2018 anchorman

“.........and another thing"
anchorman is offline  
post #7 of 20 Old 03-02-2017, 04:43 PM
Super Moderator
 
TiGrayMSM's Avatar
 
Join Date: Jan 2016
Posts: 108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Quote:
Originally Posted by anchorman View Post
The condenser/evap is a known issue. They should have done it in the first place.
This would require a competent dealership. Something I have yet to experience in my lifetime.
TiGrayMSM is offline  
post #8 of 20 Old 03-10-2017, 10:36 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Location: Holton Kansas
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Got my car back Wednesday, AC is blowing cold. They said they had never seen anything like it before. Replaced the condensor/dryer assembly. Hopefully the problem is taken care of for good.
Charlie Ireland is offline  
post #9 of 20 Old 03-23-2017, 05:04 AM
Senior Member
 
Geezer's Avatar
 
Join Date: Nov 2015
Location: Milton, Ontario Canada
Posts: 442
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 144 Post(s)
I guess I need to get in line for an AC overhaul. It has worked fine until today. It was cold outside, but the car had been standing in the sun which is very intense around noon. The car was like an oven, but when I turned on the AC is would only blow more hot air. The only way I can get cold air is to turn the temp knob fully counter-clockwise and let things cool down, then turning everything off until it gets warm again. I guess there is a lot of this type problem with the Mazda AC. Have they not come up with a fix yet?

He who works with his hands is a Labourer. He who works with his hands and his head is a Craftsman. He who works with his hands, his head and his heart is an Artist. -St. Francis of Assisi

2016 Mazda CX3 GT Tech pkg. Soul Red.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Geezer is offline  
post #10 of 20 Old 03-23-2017, 05:22 AM
Super Moderator
 
anchorman's Avatar
 
Join Date: Jul 2015
Location: Derbyshire UK
Posts: 2,078
Mentioned: 41 Post(s)
Tagged: 0 Thread(s)
Quoted: 483 Post(s)
Garage
Quote:
Originally Posted by Geezer View Post
I guess I need to get in line for an AC overhaul. It has worked fine until today. It was cold outside, but the car had been standing in the sun which is very intense around noon. The car was like an oven, but when I turned on the AC is would only blow more hot air. The only way I can get cold air is to turn the temp knob fully counter-clockwise and let things cool down, then turning everything off until it gets warm again. I guess there is a lot of this type problem with the Mazda AC. Have they not come up with a fix yet?
Where have you been Geezer! Yes, there are two issues with the CX-3 climate control. Yours sounds more like the evaporator issue.

Currently CX5 SportNav 2.2 diesel automatic and AWD.
Formerly CX3 SportNav 1.5 diesel automatic and AWD.

All advice is given in good spirit and taken entirely at the readers own risk. WORK SAFELY. ©2018 anchorman

“.........and another thing"
anchorman is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome