Heads up display - Mazda CX3 Forum
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 02-06-2018, 07:36 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Heads up display

Hi all

Recently bought a 2017 cx 3, pre registered.

Very happy with the car.

One wierd issue i have, the heads up display and the digital speedo never match...odd.

The heads up display always states 1mph more than the digital speedo in the instrument panel.

Any ideas?I

Sadly, the dealer is useless...

Thanks
Jamieb is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 02-06-2018, 08:09 PM
Super Moderator
 
anchorman's Avatar
 
Join Date: Jul 2015
Location: Derbyshire UK
Posts: 2,075
Mentioned: 41 Post(s)
Tagged: 0 Thread(s)
Quoted: 482 Post(s)
Garage
Yes, it is a feature of the HUD to behave like that. The speedo gets its inputs from the wheel speed sensors (all four of them) and the HUD gets its from the gps which just like any satnav unit runs slightly out of sync. You’ll find the cruise control syncs with the HUD which could leave you speeding in some cases. Nothing you can do as far as I know.

Currently CX5 SportNav 2.2 diesel automatic and AWD.
Formerly CX3 SportNav 1.5 diesel automatic and AWD.

All advice is given in good spirit and taken entirely at the readers own risk. WORK SAFELY. ©2018 anchorman

“.........and another thing"
anchorman is offline  
post #3 of 11 Old 02-07-2018, 12:02 AM
Super Moderator
 
Join Date: Jun 2015
Location: Seattle WA
Posts: 872
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 206 Post(s)
Are you sure the HUD gets its speed reading from GPS? That is news to me. My HUD is always spot on the digital display in the tach, i've never had a discrepancy between the readings.

2016 CX3 GT w/ i-Activesense. Black on Parchment and lovin it!
DJ9999 is offline  
 
post #4 of 11 Old 02-07-2018, 12:08 AM
Senior Member
 
Join Date: Sep 2016
Location: Southern Connecticut
Posts: 135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by DJ9999 View Post
Are you sure the HUD gets its speed reading from GPS? That is news to me. My HUD is always spot on the digital display in the tach, i've never had a discrepancy between the readings.
I'll second that. Numbers have always matched for me.
Cyclone1410 likes this.

'Perfection is not attainable, but if we chase perfection we can catch excellence." Vince Lombardi (1913-1970)

2019 CX-5 Signature Sonic Silver

2017 CX-3 Titanium Mica on Black GT AWD w/i-Activsense (Retired)
skyking is offline  
post #5 of 11 Old 02-07-2018, 06:49 AM
Senior Member
 
santa's Avatar
 
Join Date: Sep 2015
Location: Denmark
Posts: 251
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Mine match up as well, although during heavy acceleration there is a very very slight delay (way under a second) on the HUD compared to the normal speedo.

2015 Mazda CX-3 2.0 120HP Optimum Aut. Jet Black -with all the gadgets

My fuel consumption average
santa is online now  
post #6 of 11 Old 02-07-2018, 07:49 AM
Super Moderator
 
anchorman's Avatar
 
Join Date: Jul 2015
Location: Derbyshire UK
Posts: 2,075
Mentioned: 41 Post(s)
Tagged: 0 Thread(s)
Quoted: 482 Post(s)
Garage
Yes, they did match on my 16 but the ones on my CX-5 are way out and the HUD doesn’t work at all without the SD card fitted. I’m making the assumption that the op has the later version with the coloured display and it works like mine.

Currently CX5 SportNav 2.2 diesel automatic and AWD.
Formerly CX3 SportNav 1.5 diesel automatic and AWD.

All advice is given in good spirit and taken entirely at the readers own risk. WORK SAFELY. ©2018 anchorman

“.........and another thing"
anchorman is offline  
post #7 of 11 Old 02-07-2018, 08:59 AM
Senior Member
 
santa's Avatar
 
Join Date: Sep 2015
Location: Denmark
Posts: 251
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Quote:
Originally Posted by anchorman View Post
Yes, they did match on my 16 but the ones on my CX-5 are way out and the HUD doesn’t work at all without the SD card fitted. I’m making the assumption that the op has the later version with the coloured display and it works like mine.
That might explain it.
Don't You have a super cool pdf describing how the HUD works (hopefully both for the old and the new version)?

2015 Mazda CX-3 2.0 120HP Optimum Aut. Jet Black -with all the gadgets

My fuel consumption average
santa is online now  
post #8 of 11 Old 02-07-2018, 07:43 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by anchorman View Post
Yes, it is a feature of the HUD to behave like that. The speedo gets its inputs from the wheel speed sensors (all four of them) and the HUD gets its from the gps which just like any satnav unit runs slightly out of sync. You’ll find the cruise control syncs with the HUD which could leave you speeding in some cases. Nothing you can do as far as I know.
Ahh interesting... The dealer told me this, but to be honest I didn't believe them. I can't believe the two are not in sync with each other...bizzare.

A friend has a mazda 3...the speedo and HUD match.
Jamieb is offline  
post #9 of 11 Old 02-07-2018, 07:45 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by anchorman View Post
Yes, they did match on my 16 but the ones on my CX-5 are way out and the HUD doesn’t work at all without the SD card fitted. I’m making the assumption that the op has the later version with the coloured display and it works like mine.
Yes...maybe it's a UK 'thing's where they ar not in sync.
Jamieb is offline  
post #10 of 11 Old 02-07-2018, 07:45 PM
Super Moderator
 
anchorman's Avatar
 
Join Date: Jul 2015
Location: Derbyshire UK
Posts: 2,075
Mentioned: 41 Post(s)
Tagged: 0 Thread(s)
Quoted: 482 Post(s)
Garage
Quote:
Originally Posted by santa View Post
That might explain it.
Don't You have a super cool pdf describing how the HUD works (hopefully both for the old and the new version)?
Hmmm, let me see.

The first is the “original” version. The one called “dash HUD” is the latest full colour version and this is the one I have. The speed in the HUD is always faster than the speedo. Finally I’ve added the one with the TSR and on the first page it states that the system won’t work without the SD card.
Attached Files
File Type: pdf active driving display.pdf (248.7 KB, 111 views)
File Type: pdf Dash HUD.pdf (1.48 MB, 164 views)
File Type: pdf TSR.pdf (254.2 KB, 97 views)

Currently CX5 SportNav 2.2 diesel automatic and AWD.
Formerly CX3 SportNav 1.5 diesel automatic and AWD.

All advice is given in good spirit and taken entirely at the readers own risk. WORK SAFELY. ©2018 anchorman

“.........and another thing"
anchorman is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome