A/C compressor not turning - Mazda CX3 Forum
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 06-25-2019, 10:35 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A/C compressor not turning

Last Dec, I bought a pre-owned 2016 CX3. Now that it's warm, I noticed that the A/C doesn't work. Opening up the hood, the compressor does not turn when the A/C is turned on. I checked the fuses, they're good. The refrigerant is full (tried to add more and couldn't). There aren't any grinding or unusual sounds from the engine. Air still comes out the vents, just not cold.

Any ideas?

Thanks!
Jill Krynicki Dutcher is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 06-26-2019, 12:07 AM
Senior Member
 
SlyCoopers's Avatar
 
Join Date: Dec 2015
Location: Connecticut USA
Posts: 412
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 109 Post(s)
If you have any sort of warranty from a dealer I would suggest to have it addressed as soon as possible before it runs out. Its unfortunate that theres been a couple TSBs around for some 16-17 models having poorly welded evaporator or condenser (whatever the part was called cant remember exactly). Quite a few of us with 16s have had the same issue happen and it took almost 3 years for it to happen to me. Not sure if you are having a similar problem but this is one of the downsides of the early production years cx-3s. Usually the issue is refrigerant leaks out and ac just wont cool down. Yours not starting but still having full readings seems more unique and specific case however.

As a first step, is the light coming on when you set it to turn on the AC? If it doesnt there might be a broken connection in the relay to send power to the ac unit.
Also do you hear anything unusual when turning on the front defroster? The ac system should be initiated by default when using front defroster (this was how I diagnosed my ac issue in the first place in winter ironically), you wont see the light turn on in this mode however.
st3v3cx-3 likes this.

2016 CX-3 GT AWD - Crystal White Pearl Mica.
My wants-to-grow-up-to-be-a-rally-car car
SlyCoopers is offline  
post #3 of 11 Old 06-26-2019, 05:00 AM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The light does come on when I turn on the A/C.

No unusual sounds from the defroster. However, the A/C does not automatically go on when the defroster is turned on.
Jill Krynicki Dutcher is offline  
 
post #4 of 11 Old 06-26-2019, 06:35 PM
Senior Member
 
Join Date: May 2016
Location: South East UK
Posts: 210
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Quote:
Originally Posted by Jill Krynicki Dutcher View Post
Last Dec, I bought a pre-owned 2016 CX3. Now that it's warm, I noticed that the A/C doesn't work. Opening up the hood, the compressor does not turn when the A/C is turned on. I checked the fuses, they're good. The refrigerant is full (tried to add more and couldn't). There aren't any grinding or unusual sounds from the engine. Air still comes out the vents, just not cold.

Any ideas?

Thanks!
Is there no really cold air at all, even when the temperature is set to the minimum? If there is some at the minimum setting, but none otherwise, it could point to a faulty control unit panel - the three dials section - which was also a problem on early CX-3's along with the evaporator and condenser problems mentioned by SlyCoopers in his post. It should be covered by warranty if you still have some left, or possibly some kind of goodwill part payment. I think you need to take you car to your dealer for them to investigate and advise on a fix.

2016 Sport Nav 2.0 Petrol Automatic Arctic White plus options
st3v3cx-3 is offline  
post #5 of 11 Old 06-26-2019, 08:36 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That's correct- no cold air, no cool air comes out when the A/C is on.

Thanks for the input. I guess I'll have to take it in.
Jill Krynicki Dutcher is offline  
post #6 of 11 Old 06-26-2019, 10:06 PM
Member
 
Join Date: Sep 2015
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
You can't add refrigerant without the compressor running. If you try, the pressure will read full or high, but no refrigerant will go in. It's likely that the system has leaked, and the compressor won't turn on due to low refrigerant. I would recommend, as Sly suggested, to take it to the dealer ASAP if it has any sort of warranty. Even if it's out of warranty, take it to the dealer and see if Mazda is willing to cover part or all of the repair costs.

TSB ID 07-004-17-3332a
TSB ID 07-001-18-3465
TSB ID 07-001-18-3274b
inflex is offline  
post #7 of 11 Old 06-27-2019, 02:48 AM
Super Moderator
 
anchorman's Avatar
 
Join Date: Jul 2015
Location: Derbyshire UK
Posts: 2,078
Mentioned: 41 Post(s)
Tagged: 0 Thread(s)
Quoted: 483 Post(s)
Garage
The compressor doesn’t run full time, it cuts in and out as required. The fans always run when the compressor runs.

Currently CX5 SportNav 2.2 diesel automatic and AWD.
Formerly CX3 SportNav 1.5 diesel automatic and AWD.

All advice is given in good spirit and taken entirely at the readers own risk. WORK SAFELY. ©2018 anchorman

ď.........and another thing"
anchorman is offline  
post #8 of 11 Old 07-04-2019, 04:57 AM
Junior Member
 
Join Date: Jun 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
When the freon is low the compressor will not cycle, and will run continuously until the pressure is at the proper range. Also no cooling will not allow it to cycle on low temp.

He should try to supply the compressor with 12v directly and see if it turns then and trouble shoot backwards electrically from that point....

Last edited by jcy110; 07-04-2019 at 04:59 AM.
jcy110 is offline  
post #9 of 11 Old 07-10-2019, 10:53 PM
Junior Member
 
Join Date: Jul 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Hi.. I just joined the forum.. found out Saturday that my 2016 ac compressor was leaking.. 28k miles.. used it for 2 summers in NY.. just 3 months out of my warranty.. also found out there is a TSB regarding this sent out in January 2019.. I’m very disappointed with my first time Mazda purchase. Hoping this eventually turns into a recall so I can be reimbursed for all the money I had to spend on a new compressor!
Michele Vanessa is offline  
post #10 of 11 Old 07-11-2019, 12:49 AM
Senior Member
 
SlyCoopers's Avatar
 
Join Date: Dec 2015
Location: Connecticut USA
Posts: 412
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 109 Post(s)
Quote:
Originally Posted by Michele Vanessa View Post
Hi.. I just joined the forum.. found out Saturday that my 2016 ac compressor was leaking.. 28k miles.. used it for 2 summers in NY.. just 3 months out of my warranty.. also found out there is a TSB regarding this sent out in January 2019.. Iím very disappointed with my first time Mazda purchase. Hoping this eventually turns into a recall so I can be reimbursed for all the money I had to spend on a new compressor!
Sorry to hear that, I would try to get in contact with mazda USA operations customer service. Usually theyre pretty good about this stuff especially with a tsb since its a 'known' but not recalled issue so you have grounds for a case in your favor.

2016 CX-3 GT AWD - Crystal White Pearl Mica.
My wants-to-grow-up-to-be-a-rally-car car
SlyCoopers is offline  
Reply

Tags
a/c , compressor , troubleshooting

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome