Infotainment/Navi screen blank - Mazda CX3 Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 09-21-2016, 03:00 PM Thread Starter
Super Moderator
 
NotAPreppie's Avatar
 
Join Date: Aug 2016
Location: Chicago, IL, USA, North America, Earth, Sol System, Sector ZZ9 Plural Z Alpha, Milkyway, Universe
Posts: 526
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 140 Post(s)
Garage
Infotainment/Navi screen blank

So, in between parking the car Monday night and starting it up to head to work Tuesday morning the infotainment/nav screen has packed up.

The radio still works but nothing is displayed. I tried the Music+Nav+Mute for 10s reboot combo but that didn't fix it. I also disconnected the car's battery for several hours but that didn't work either.

Any ideas before I have to deal with the hassle of a dealer visit?


2016 CX-3 GT iAS AWD, Soul Red Metallic on black
2017 MX-5 RF Launch Edition
2005 RX-8 Sport Sunlight Silver under Cone Rash (because racecar!) -- SOLD!

Science adjusts it's views based on what's observed.
Faith is the denial of observation so that belief can be preserved.
-Tim Minchin.
NotAPreppie is online now  
Sponsored Links
Advertisement
 
post #2 of 8 Old 09-22-2016, 02:21 AM
Senior Member
 
Snoogie's Avatar
 
Join Date: Oct 2015
Location: Wisconsin, Madison
Posts: 234
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 56 Post(s)
Garage
Would you happen to know what version of the infotainment you are running? The current version is 590 which is "suppose" to address that issue from previous versions. Otherwise have the dealership deal with it, its their job.

Certified Mazda Technician
Snoogie is offline  
post #3 of 8 Old 09-22-2016, 03:22 AM Thread Starter
Super Moderator
 
NotAPreppie's Avatar
 
Join Date: Aug 2016
Location: Chicago, IL, USA, North America, Earth, Sol System, Sector ZZ9 Plural Z Alpha, Milkyway, Universe
Posts: 526
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 140 Post(s)
Garage
No idea. It's going to the dealer tomorrow morning.

On the bright side, I discovered that the voice commands still work. So I got that going for me, which is nice.


2016 CX-3 GT iAS AWD, Soul Red Metallic on black
2017 MX-5 RF Launch Edition
2005 RX-8 Sport Sunlight Silver under Cone Rash (because racecar!) -- SOLD!

Science adjusts it's views based on what's observed.
Faith is the denial of observation so that belief can be preserved.
-Tim Minchin.
NotAPreppie is online now  
 
post #4 of 8 Old 10-09-2016, 03:35 PM
Junior Member
 
Join Date: Oct 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by NotAPreppie View Post
No idea. It's going to the dealer tomorrow morning.

On the bright side, I discovered that the voice commands still work. So I got that going for me, which is nice.

I have the exact same problem today. What was the solution here? Many thnks
Timsarge is offline  
post #5 of 8 Old 10-09-2016, 04:17 PM
bjn
Member
 
bjn's Avatar
 
Join Date: Apr 2016
Location: Denmark
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
I have experienced completely the same thing several times. It dos not always helps to turn the system off and on again, the only thing I have found that helps is to turn off the system (the whole car), remove the SD card, turn on the engine and when the sign "you do not have navigation, insert the navigation SD card is in ..."shows up , put the SD card back in and then it normally comes to live again (the radio is always playing?). There can be 1-3 weeks between the system breaks down, which is frustrating when you meet up at the workshop and trying to explain the mistake ... and they send you a pathetic smile... because everything is working fine.. Doeeh
I've now filmed system several times where it does not start up for documentation.

For your information, I can tell that my Infotainment system is updated to the newest version.

Mazda CX-3 150 AWD Automatic Optimum 2016 -
Honda Civic Sport 1.8 Automatic 2012 -
bjn is offline  
post #6 of 8 Old 10-09-2016, 07:32 PM Thread Starter
Super Moderator
 
NotAPreppie's Avatar
 
Join Date: Aug 2016
Location: Chicago, IL, USA, North America, Earth, Sol System, Sector ZZ9 Plural Z Alpha, Milkyway, Universe
Posts: 526
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 140 Post(s)
Garage
My solution was to take it to the dealer and have them replace things.


2016 CX-3 GT iAS AWD, Soul Red Metallic on black
2017 MX-5 RF Launch Edition
2005 RX-8 Sport Sunlight Silver under Cone Rash (because racecar!) -- SOLD!

Science adjusts it's views based on what's observed.
Faith is the denial of observation so that belief can be preserved.
-Tim Minchin.
NotAPreppie is online now  
post #7 of 8 Old 10-10-2016, 08:03 PM
Senior Member
 
Vipre77's Avatar
 
Join Date: Sep 2015
Location: Milwaukee, WI, USA
Posts: 327
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 76 Post(s)
Garage
Mine did that except the radio became completely unresponsive to everything except the rear camera view still worked, but I couldn't access any of the settings in the menu. The dealership ended up replacing the computer located in the dash directly below the display.

His: 2018 Mazda6 Grand Touring, Machine Grey Metallic
Hers: 2016 CX-5 Sport, FWD, Reflex Blue
Vipre77 is offline  
post #8 of 8 Old 10-11-2016, 05:46 AM
Junior Member
 
Join Date: Oct 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi all, to update everyone. Seems like a terminal problem. Mazda have decided to replace the entire unit free of charge, Car is only 4 weeks old, 1700kms. Everything seems responsive also except screen. Mazda say approx 1 week for arrival. I'm in Phuket, Thailand.
Timsarge is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome